Home Forum Verticaal zoeken Verticaal zoeken Complex

Dit onderwerp bevat 5 reacties, heeft 2 stemmen, en is het laatst gewijzigd door  Danny 1 maand, 1 week geleden.

6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)
  • Auteur
    Berichten
  • #11183 Reactie

    Hans van Vessum

    Beste Danny,

    Onderstaand een databank in Excel, dit om wachtwoorden te maken. Ik moet hiervoor een programmaatje maken. Door een gekozen 8-letterwoord bijvoorbeeld; ‘theeroos’ moet d.m.v verticaal zoeken een wachtwoord verschijnen. Mijn kennis van Excel is te beperkt en kan de formule die ik hiervoor nodig hebt niet maken. Wellicht kan jij me helpen aan deze formule
    =VERT.ZOEKEN() en dan ?

    Hartelijk dank voor je medewerking.

    Met een vriendelijke groet,
    Hans van Vessum

    a Z # J o 1 3 T k
    b A # s p 2 2 U m
    c B # M M 3 1 V n
    d C # N r # 2 W o
    e D # O s 5 4 X p
    #11186 Reactie

    Danny
    Sleutelbeheerder

    Hallo Hans,

    Is het de bedoeling dat op individuele letters of een basis van het 8-letterwoord een wachtwoord wordt opgehaald?
    Het mij nog niet helemaal duidelijk wat link is tussen het woord en het databank.

    Kan jij mij uitleggen wat daar de link tussen is, of desnoods het bestand mailen? Dan kan ik je inhoudelijk wat meer vertellen.

    Sowieso heb ik op mijn site uitgeschreven hoe verticaal zoeken werkt in. Zie link, kan je daar wat mee?

    Verticaal zoeken (vLookup)

    #11187 Reactie

    Hans

    Beste Danny,

    Bedankt voor de snelle reactie, de bedoeling is op individuele letter dus 8 letters een wachtwoord wordt gegenereerd.

    Mijn voorbeeld is dus ‘theeroos’, zie tabel, het wachtwoord wordt dan “S#Os2Fb

    Met de uitleg van artikel verticaal zoeken kom ik er niet uit.

    Ik stuur hierbij het Excel bestand, zodat het duidelijker is.

    Nogmaals hartelijk dank voor u medewerking.

    Vriendelijke groet,
    Hans van Vessum

    #11190 Reactie

    Danny
    Sleutelbeheerder

    Hallo Hans,

    Dit is inderdaad wat ik had verwacht. Ik heb de formules voor je toegevoegd;

    In O7 =VERT.ZOEKEN(DEEL($O$5;1;1);$A2:$I$27;2;ONWAAR)

    In V7 =VERT.ZOEKEN(DEEL($O$5;8;1);$A2:$I$27;9;ONWAAR)

    excel_oplossing_verticaalzoeken_wachtwoorden2

    Ook heb ik er een beveiliging ingezet via gegevensvalidatie, zodat je altijd een 8 letter woord intikt. Iets anders geeft een foutmelding.

    excel_oplossing_verticaalzoeken_wachtwoorden_onjuist

    Het wachtwoord staat in cel O6 maar ook in de cellen eronder (O7:V7), ik laat de keuze aan jou om te bepalen wat je makkelijker vindt.

    In O6 heb ik alle verticaal zoeken formules samengevoegd in 1 cel dat ziet er zo ui:

    =VERT.ZOEKEN(DEEL($O$5;1;1);$A2:$I$27;2;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;2;1);$A2:$I$27;3;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;3;1);$A2:$I$27;4;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;4;1);$A2:$I$27;5;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;5;1);$A2:$I$27;6;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;6;1);$A2:$I$27;7;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;7;1);$A2:$I$27;8;ONWAAR)&VERT.ZOEKEN(DEEL($O$5;8;1);$A2:$I$27;9;ONWAAR)

    Kan jij zo verder?

     

    #11191 Reactie

    Hans

    Bedankt voor het oplossen van mijn vraagstuk. De oplossing is toch wel te ingewikkeld voor mij.

    Met een vriendelijke groet,

    Hans

    #11194 Reactie

    Danny
    Sleutelbeheerder

    Goed om te horen dat het is opgelost!

6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)
Reageer op: Verticaal zoeken Complex
Mijn informatie: